intfiction.org

The Interactive Fiction Community Forum
It is currently Wed Dec 19, 2018 3:40 am

All times are UTC - 6 hours [ DST ]




Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Anno 1700
PostPosted: Mon Oct 01, 2018 11:13 pm 
Offline

Joined: Fri Oct 02, 2015 8:05 pm
Posts: 17
I can't get the blorb to run with Glulxe. Anyone else having this problem?


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 2:45 am 
Offline
User avatar

Joined: Sat Jun 13, 2009 3:08 pm
Posts: 117
Location: Denmark
mstahl wrote:
I can't get the blorb to run with Glulxe. Anyone else having this problem?

I have tried running the blorb on my computer and it works fine...
I'm looking into the problem, but would be grateful for any help...

_________________
Work in progress: D-Day (Adrift V.5)


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 2:52 am 
Offline

Joined: Thu Nov 05, 2015 7:15 pm
Posts: 20
This is an ADRIFT 5 game. You need to use the ADRIFT runner from http://www.adrift.co/download.
There are two versions of the runner, one for windows and one for Linux with Mono (Which might also work on Mono for Mac but nobody with a Mac seems to have tried it yet)


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 3:10 am 
Offline

Joined: Wed Nov 12, 2014 5:20 pm
Posts: 205
I tried it on a Mac without success. See this thread.


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 4:05 am 
Offline

Joined: Fri Oct 02, 2015 8:05 pm
Posts: 17
I downloaded the ADRIFT runner. It won't run the game, saying that it's not a .taf file. Well, of course it's not, it's a .blorb file! :lol: Any other suggestions? I'm wondering why it's being called a .blorb file if it won't run on Glulxe. Do I need a new version of Glulxe perhaps?


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 5:08 am 
Offline

Joined: Fri Feb 04, 2011 3:20 pm
Posts: 38
I just tried it using Gargoyle (universal interpreter which can run Adrift games), both as the .blorb and renaming it with .taf. In neither case would it run.
EDIT: Just to see, I tried running it on my Android tablet in Fabularium, which is based on Gargoyle, and it worked fine there. The .glorb file, that is. No problems. Weird.


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 7:10 am 
Offline
User avatar

Joined: Tue Nov 08, 2011 8:11 am
Posts: 2807
Location: US - Central
In my brief foray experimenting with Adrift, it seemed like there was a website you could go to and insert the path of an Adrift game hosted online to run it in the browser?

http://play.adrift.org.uk/?game=URL
(replacing URL with the address of the game)

Dunno if that's helpful.

_________________
http://hanonondricek.wixsite.com/pyramidif
https://pyramidif.itch.io/


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 7:12 am 
Offline

Joined: Thu Nov 05, 2015 7:15 pm
Posts: 20
A .blorb file is a container format that can have ANY interactive fiction format inside of it (along with pictures and sound files).
Unfortunately Gargoyle and Glulxe currently only support a few of these formats.
Gargoyle runs very OLD ADRIFT games, it does not run ADRIFT 5 games! However Fabularium has been updated for ADRIFT 5 (I don't know how well it works, but make sure you have at least version 1.4.0)

Here are step-by-step installation instructions for ADRIFT 5 on a windows PC:
1. Go to http://www.adrift.co/download
2. Download ADRIFT5Setup.zip
3. Unzip, which should produce a single file called Setup.exe
4. Run Setup.exe to install ADRIFT 5.0
5. The interpreter is called Run500.exe, run it and open the BLORB file from its file menu.
6. If it doesn't work your computer may be missing v4 of the NET framework (see http://wiki.adrift.co/General_Setup for more info)

The Linux Mono version is called adrift-5.0.35.tar.gz and is on the same download page.


Last edited by saabie on Tue Oct 02, 2018 7:48 am, edited 1 time in total.

Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 7:19 am 
Offline

Joined: Mon Feb 22, 2016 1:01 pm
Posts: 16
mstahl wrote:
I downloaded the ADRIFT runner. It won't run the game, saying that it's not a .taf file. Well, of course, it's not, it's a .blorb file! :lol: Any other suggestions? I'm wondering why it's being called a .blorb file if it won't run on Glulxe. Do I need a new version of Glulxe perhaps?
Sounds like you downloaded the ADRIFT 4 runner. ADRIFT 4 Runner doesn't run ADRIFT-blorbs. ADRIFT-Blorbs were first possible with ADRIFT 5, so you need to install ADRIFT 5 to play the game. Unlike ADRIFT 4, the download file for ADRIFT 5 contains both a runner and a developer.


Top
 Profile Send private message  
Reply with quote  
 Post subject: Re: Anno 1700
PostPosted: Tue Oct 02, 2018 8:08 am 
Offline

Joined: Fri Oct 02, 2015 8:05 pm
Posts: 17
saabie wrote:
6. If it doesn't work your computer may be missing v4 of the NET framework (see http://wiki.adrift.co/General_Setup for more info)


Yeah, I initially tried installing ADRIFT 5 and got that message. I'll try that. Thank you everyone for all the help!


Top
 Profile Send private message  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 16 posts ]  Go to page 1, 2  Next

All times are UTC - 6 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group