intfiction.org
https://www.intfiction.org/forum/

Problems with Wade Clarke's menus?
https://www.intfiction.org/forum/viewtopic.php?f=7&t=26242
Page 1 of 1

Author:  seeva [ Tue May 15, 2018 1:18 pm ]
Post subject:  Problems with Wade Clarke's menus?

Having the following issue with Wade Clarke's menus:

Quote:
The sentence 'current menu is the table of help contents' tells me that 'current menu', which is a table name that varies, should start out with the value 'table of help contents', but this is an object and not a table name.


I'm using Inform 7 build 6G60, does anyone know a quick fix for this?

Author:  severedhand [ Sat May 19, 2018 1:35 am ]
Post subject:  Re: Problems with Wade Clarke's menus?

Hi, this is Wade. I haven't had to touch my own extension for a few years now but I can turn to its documentation to try to help troubleshoot.

I think the first thing to check is make sure you've got the right version of the extension installed for your version of Inform.

If it's a 6G60 project, you need Menus v2. (For a version of Inform later than 6G60, you would use v3.)

There's probably more than one place you can download v2 these days. I'm not sure where those places are, so it will be simplest if I attach v2 to this post.

If you are already using v2 (check by looking in the first line of the extension, or by typing 'version' if you can get your game to run with the extension in it --- except you currently can't ---) then there may be some kind of table/variable naming clash with another extension you're using.

But step 1 is --- check whether using v2. If not, install v2, make sure Inform is definitely referencing v2 when it tries to build, then see if it does build. Let me know how you go.

-Wade

Attachments:
File comment: This is version 2 of menus by Wade Clarke, specifically for Inform 6G60.
Menus.i7x [122.29 KiB]
Downloaded 15 times

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group
https://www.phpbb.com/